We are currently investigating performance issues with the Workplace platform. Users may experience slow load times or intermittent errors. We apologize for the disruption and will provide an update shortly.

Incident Report for OfficeRnD

Resolved

This incident has been resolved.
Posted Sep 30, 2025 - 16:39 EEST

Update

We are continuing to investigate this issue.
Posted Sep 30, 2025 - 16:39 EEST

Investigating

We are currently investigating this issue.
Posted Sep 30, 2025 - 16:06 EEST
This incident affected: Workplace Platform.