Issues with Email delivery
Incident Report for OfficeRnD
Resolved
The issue has been resolved and the emails are being delivered timely.
Posted Jun 10, 2022 - 07:05 EEST
Monitoring
The issue has been resolved by our provider. We are monitoring the issue closely.
Posted Jun 10, 2022 - 00:46 EEST
Identified
Email delivery is still slow. We will update you once the issue is resolved. In the meantime, you can track our provider status page here: https://status.mailgun.com/incidents/gcm3zw1lvfl4.
Posted Jun 09, 2022 - 20:06 EEST
Monitoring
Our mail delivery provider has resolved their issues, so emails should be delivered on time now.
Posted Jun 09, 2022 - 19:18 EEST
Investigating
We are currently experiencing issues with the email delivery, related to an incident our provider (Mailgun) has right now. They are currently working on resolving the issue and the emails are being successfully sent, but are experiencing delays.

You can also check our provider status here: https://status.mailgun.com/incidents/gcm3zw1lvfl4
Posted Jun 09, 2022 - 18:54 EEST
This incident affected: Flex Platform, Flex Platform API, Hybrid Platform, and Hybrid Platform API.